Skip to main content
← All vulnerabilities
CVE-2026-22592GO-2026-4451GHSA-CR88-6MQM-4G57

Gogs is Vulnerable to Denial of Service

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 0.14.0+dev, 0.13.4
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: partial

Summary

Gogs is an open source self-hosted Git service. In version 0.13.3 and prior, an authenticated user can cause a DOS attack. If one of the repo files is deleted before synchronization, it will cause the application to crash. This issue has been patched in versions 0.13.4 and 0.14.0+dev.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • gogs gogs

    fixed in 0.14.0+dev; fixed in 0.13.4

  • gogs.io/gogsGo

    All versions

  • gogs.io/gogsGo

    fixed in 0.13.4

References 1

GitHub · gogs/gogs