Command Injection Vulnerability on TP-Link Archer BE230 v1.2 and BE3600 v1
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.2.4 Build 20251218 rel.70420, (KR)_V1_1.2.2 Build 20260903, (EU)_V1_1.2.6 Build 20260617, (USW)_V1.26_1.2.6 Build 20260617
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
An OS Command Injection vulnerability in TP-Link Archer BE230 v1.2(vpn modules) and BE3600 v1 allows adjacent authenticated attacker execute arbitrary code. Successful exploitation could allow an attacker to gain full administrative control of the device, resulting in severe compromise of configuration integrity, network security, and service availability. This CVE covers one of multiple distinct OS command injection issues identified across separate code paths. Although similar in nature, each instance is tracked under a unique CVE ID. This issue affects Archer BE230 v1.2 < 1.2.4 Build 20251218 rel.70420.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- TP-Link Systems Inc. Archer BE230 v1.2
fixed in 1.2.4 Build 20251218 rel.70420
- TP-Link Systems Inc Archer BE3600 V1
fixed in (KR)_V1_1.2.2 Build 20260903; fixed in (EU)_V1_1.2.6 Build 20260617; fixed in (USW)_V1.26_1.2.6 Build 20260617