Skip to main content
← All vulnerabilities
CVE-2026-2052

Widget Options <= 4.2.2 - Authenticated (Contributor+) Remote Code Execution via Display Logic

Published
Last modified
published
Not listed in CISA KEV
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

The Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 4.2.2 via the Display Logic feature. This is due to the plugin using eval() on user-supplied Display Logic expressions with an insufficient blocklist/allowlist that can be bypassed using array_map with string concatenation, combined with a lack of authorization enforcement on the extended_widget_opts_block attribute. This makes it possible for authenticated attackers, with Contributor-level access and above, to execute code on the server. The vulnerability was partially patched in version 4.2.0.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • marketingfire Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets

    through 4.2.2

  • Marketing Fire, LLC Widget Options - Extended

    through 5.3.2

References 6

wordfence.com

plugins.trac.wordpress.org