Skip to main content
← All vulnerabilities
CVE-2026-18024

PostgreSQL ascii() function reads past end of buffer

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 18.6, 17.11, 16.15, 15.19, 14.24
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Buffer over-read in PostgreSQL ascii() SQL function allows a user to disclose up to 3 bytes after the end of a specific allocation, via a crafted text value. This is the same class of defect that CVE-2026-2006 fixed, though this instance has less impact. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • n/a PostgreSQL

    From 18 · fixed in 18.6; From 17 · fixed in 17.11; From 16 · fixed in 16.15; From 15 · fixed in 15.19; fixed in 14.24

References 1

postgresql.org